Jump to content
Argus WoW Best Legion Server
VerusDK

Bug In StormHeim Invasion points

Recommended Posts

So, when i am trying to clear wqs in stormheim for like just normal wqs or just the legion invasion points ones they dont show up, neither does the normal wqs and they do in other zones such as Azuna, Highmountain and even Broken Shore, StormHeim is the only zone where this happends, Ive tried using the control panel to " Repair " my charecter this happends on but that dosent work, ive tried to relog, nothing happends, no one know why this is happening so im trying here to see if anyone have had this issue before and maybe knows how to fix this so i can clear some of the content avaible in this particular zone. There is screenshots linked in this post so you can see what is going on. 

WoWScrnShot_100319_023926.jpg

WoWScrnShot_100319_025253.jpg

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×