Jump to content
Argus WoW Best Legion Server
Sign in to follow this  

Unable to acquire the Fist of Ra-Den elemental shaman artifact weapon

Recommended Posts

The [Codex of Ra] quest given by Xuen in Kun lai summit at the temple of the white tiger is not working.

0/1 Travel to the Goul-Lal halls is not popping in when you get there
It doesn't changes phase to its specific quest phase so theres no quest items or the mobs that you have to kill namely Mogu spirits. 

I have tried different aproaches but none of them worked.
Also theres an option to tell Xuen that you are Ready then he proceeds to get to an arena where then he stays forever and you can't talk to him again.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this