Jump to content
Argus WoW Best Legion Server
  • 0
Sign in to follow this  
Rhawkie

Monk Mistweaver Artifact quest bugged?

Question

When I go to Skywall to obtain the Mistweaver Artifact weapon. it says that I am on a different scenario "The Broken Shore" and the image of Typhynius mobs aren't attackable. I can also not get to the final boss, Typhynius, and thus not get the artifact weapons. I have tried relogging, retaking the quest, clearing cache, but nothing is working

Please help

Share this post


Link to post
Share on other sites

2 answers to this question

Recommended Posts

  • 0
15 minutes ago, Rhawkie said:

When I go to Skywall to obtain the Mistweaver Artifact weapon. it says that I am on a different scenario "The Broken Shore" and the image of Typhynius mobs aren't attackable. I can also not get to the final boss, Typhynius, and thus not get the artifact weapons. I have tried relogging, retaking the quest, clearing cache, but nothing is working

Please help

EDIT:  Whilst moving on to another quest "Mysterious Lightbound Object" and then moving on to the scenario thereafter, it is again glitched to make it "The Broken Shore Scenario". So it seems that every scenario will now be bugged by this Broken Shore scenario (Which I can also not complete).

Share this post


Link to post
Share on other sites
  • 0

we have not yet found how to repeat this bug to fix it (((but after restarting the server you must successfully pass the scenario to the artifact

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×